Go to a  "printer friendly" view of this message which allow an easy print Printer-friendly copy Go to the page which allows you to send this topic link and a message to a friend Email this topic to a friend
Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D90/D80/D70 (Public) topic #251876
View in linear mode

Subject: "Nikon D80 cable shutter MC-DC1: cable or camera malfunc..." Previous topic | Next topic
opoloko Registered since 26th Sep 2012Wed 26-Sep-12 06:55 PM
3 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
"Nikon D80 cable shutter MC-DC1: cable or camera malfunction??"


GB
          

Hi all,

for the first time I decided to use a cable shutter release as
I need to take long exposure pictures one after the other,
without staying near the camera. I found on eBay several
models by Shoot brand like this one

http://www.ebay.co.uk/itm/Timer-Remote-Shutter-Release-for-NIKON-D70s-D80-MC-DC1-/220769581310?pt=UK_Photography_DigitalCamAccess_RL&hash=item3366e478fe

I received the item, set the camera on Manual/Bulb/Manual
focus etc., but as soon as I connect the cable to the camera
it starts exposing..even without batteries in the remote. If I
connect it before switching on the camera, as soon as I switch
on the camera it starts exposing. I also tried setting
exposure time to 2 seconds..it takes the picture but when
finished it does not show the picture just taken until I
disconnect the shutter cable.

The odd thing is also that after this first picture, I cannot
use anymore the main shutter button on the camera or the one
on the remote..it just does not work. But as soon as I
disconnect the remote the previous picture appears on the back
screen, and I can use again the camera or connect the remote
but only for one picture..

If I set the timer on the remote shutter it expose correctly
the first picture, for example for 60s, but then it looks like
the camera 'hangs' without showing the picture taking and
unable to take any other picture until I disconnect the remote
shutter, the previous picture appear on the screen and all
goes back to normal.


Any idea? Could it be the cheap remote shutter cable broken?
Is it a problem of the camera? Any advice is welcome...thanks!

  

Alert Printer-friendly copy | Reply | Reply with quote

A general, generic topicNikon D80 cable shutter MC-DC1: cable or camera malfunc... [View all] , opoloko , Wed 26-Sep-12 06:55 PM
 
Subject Author Message Date ID
Reply message RE: Nikon D80 cable shutter MC-DC1: cable or camera mal...
MEMcD Moderator
26th Sep 2012
1
Reply message RE: Nikon D80 cable shutter MC-DC1: cable or camera mal...
opoloko
26th Sep 2012
2
     Reply message RE: Nikon D80 cable shutter MC-DC1: cable or camera mal...
MEMcD Moderator
27th Sep 2012
3
          Reply message RE: Nikon D80 cable shutter MC-DC1: cable or camera mal...
spanglerokapi Silver Member
27th Sep 2012
4
               Reply message RE: Nikon D80 cable shutter MC-DC1: cable or camera mal...
opoloko
27th Sep 2012
5

Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D90/D80/D70 (Public) topic #251876 Previous topic | Next topic


Take the Nikonians Tour and learn more about being a Nikonian Wiki /FAQ /Help Listen to our MP3 photography radio channels Find anything on Nikon and imaging technology - fast!

Copyright © Nikonians 2000, 2014
All Rights Reserved

Nikonians®, NikoScope® and NikoniansAcademy™ are trademarks owned by Nikonians.org.
Nikon®, Nikonos® and Nikkor® are registered trademarks of Nikon Corporation.