Go to a  "printer friendly" view of this message which allow an easy print Printer-friendly copy Go to the page which allows you to send this topic link and a message to a friend Email this topic to a friend
Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D5300/D5200/D5100/D5000/D3300/D3200/D3100/D3000 (Public) topic #6901
View in linear mode

Subject: "Flash disabled in auto mode" Previous topic | Next topic
Claire85 Registered since 18th Oct 2012Thu 18-Oct-12 12:02 PM
4 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
"Flash disabled in auto mode"


GB
          

On auto mode on my Nikon D5100 my flash appears to be disabled. It works in manual but not auto, where if I look at the settings ('i') flash is showing as off. As far as I was aware I couldn't disable flash in auto so I'm v. Confused and frustrated. It's now operating like the flash off auto mode. Can anyone help? Pleeaase? I'm in Madagascar and missing out on lots of amazing photo opportunities!! Thanks in advance!

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Replies to this topic
Subject Author Message Date ID
Reply message RE: Flash disabled in auto mode
jpFoto
18th Oct 2012
1
Reply message RE: Flash disabled in auto mode
Claire85
18th Oct 2012
3
Reply message RE: Flash disabled in auto mode
Claire85
18th Oct 2012
2
Reply message RE: Flash disabled in auto mode
avigar Silver Member
18th Oct 2012
4
     Reply message RE: Flash disabled in auto mode
Claire85
18th Oct 2012
5
          Reply message RE: Flash disabled in auto mode
jpFoto
18th Oct 2012
6
Reply message RE: Flash disabled in auto mode
avm247 Moderator
18th Oct 2012
7
Reply message RE: Flash disabled in auto mode
wdcrvr Silver Member
19th Oct 2012
8

jpFoto Registered since 25th Jun 2010Thu 18-Oct-12 12:29 PM
1114 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#1. "RE: Flash disabled in auto mode"
In response to Reply # 0


US
          

Cllaire,

As a quick band aid to your problem, I have two thoughts:

1. If you have your User's Manual available, read page 38. If not, in Auto Mode, press the i button once or twice depending upon where you are. Place the cursor in the information display and toggle over to and highlight the flash mode icon. Press ok and then select your preferred mode and hit ok again. You may have had the flash off.

2. In auto mode the flash only works when the camera calls for the additional light. So, it's possible that the scene isn't dark enough to call for flash.

Good luck and hopefully someone with more experience with "Auto Mode" and flash can confirm or supplement these recommendations.

jP

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
Claire85 Registered since 18th Oct 2012Thu 18-Oct-12 02:53 PM
4 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#3. "RE: Flash disabled in auto mode"
In response to Reply # 1


GB
          

P.S. thanks for your help JP. It thinks 'auto' is 'auto flash off' which explains the odd behaviour but I can't switch the flash on in this mode. I'm sure I'll manage, there'll just be a few blurry lemurs at the end of the trip!

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Claire85 Registered since 18th Oct 2012Thu 18-Oct-12 02:48 PM
4 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#2. "RE: Flash disabled in auto mode"
In response to Reply # 0


GB
          

UPDATE: so it appears that my camera isn't recognizing when I change between the different modes, portrait and landscape are skipped entirely when I change te dual. It thinks manual is auto etc... Seems like a software problem but any advice is still gratefully appreciated!!!

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
avigar Silver Member Nikonian since 29th Nov 2006Thu 18-Oct-12 04:42 PM
486 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#4. "RE: Flash disabled in auto mode"
In response to Reply # 2


Northern IL, US
          

Have you tried a hard reset? Also, check your firmware version. The most current for the D5100 is v1.01. You can also try to re-flash the firmware if it's already the current version. Otherwise, it will need to be sent off to Nikon repair. Good luck.

--Ben

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

        
Claire85 Registered since 18th Oct 2012Thu 18-Oct-12 07:48 PM
4 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#5. "RE: Flash disabled in auto mode"
In response to Reply # 4


GB
          

Hi Ben, is there a way I can do that without a computer? Access is more than a little limited out here!

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

            
jpFoto Registered since 25th Jun 2010Thu 18-Oct-12 10:07 PM
1114 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#6. "RE: Flash disabled in auto mode"
In response to Reply # 5
Thu 18-Oct-12 10:22 PM by jpFoto

US
          

HI Claire

Assuming that you are still wrestling with this, you can do the hard reset without a computer, but you can't update the firmware.

I agree that you should try the "two button" reset. It will reset any menu items that you have stored, and it will put your camera back to factory settings. The reset buttons are the "i or information" button and the "menu" button. Hold them both down at the same time. You will probably get a message on the display that asks if you really want to that. Answer OK or whatever allows it to proceed. After the reset, I would probably take the battery out for about 30 seconds, but don't ask me why.

Let us know if that works. If not, maybe we can suggest a way that you can get the Lemurs in focus by using P (Program Mode) and Auto-ISO by choosing ISO 100 with a maximum ISO of up to ISO 3200 with a minimum shutter speed of 1/60. That would be my preference anyway over flash if it's a possibility.

Good luck.

jP

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

avm247 Moderator Awarded for high skills in documentary architecture and aviation photography Charter MemberThu 18-Oct-12 11:00 PM
18404 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#7. "RE: Flash disabled in auto mode"
In response to Reply # 0
Thu 18-Oct-12 11:03 PM by avm247

Rancho Cordova, US
          

Claire, if you want an "auto mode" but don't want to use flash, you can use Program mode (P) - and it should also adjust your ISO and exposure to get the shot, but you will to pay attention to the shutter speed in lower light to make sure you won't get blur due to camera shake during a longish exposure, especially if you are not using external camera support.

If you WANT flash in Program, just pop it up, it should fire when popped up. It should flash "HI" when it detects overexposure.

(As I understand auto mode, it will determing exposure and will use flash whenever it feels light levels are too low for handholding. Not sure why you are not getting it (the flash) to work in Auto mode.)

(When you have a chance, you might consider resetting to factory and see if that clears it up.)

In case you need the manual: http://www.nikonusa.com/pdf/manuals/dslr/D5100_EN.pdf

What flash mode are you using?


Anthony

The Moderator Page and My Gallery
The important things in life are simple; the simple things are hard.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
wdcrvr Silver Member Nikonian since 18th Sep 2012Fri 19-Oct-12 12:01 PM
79 posts Share on Facebook Share on Twitter Share on Linkedin    Click to send email to this author Click to send private message to this authorClick to view this author's profile
#8. "RE: Flash disabled in auto mode"
In response to Reply # 7


Vancouver, CA
          

Hi Clare,

Is your camera by any chance set to "continuous" shooting mode in the Release menu? (Info screen, fourth item down on the right side, icon that looks like three overlapping windows).
Does you camera continue to take pictures for as long as you have your finger on the shutter button?

I believe that the flash is disabled when you're in this mode, because the flash can't keep up with the frame rate when you are shooting multiple images in a burst. If you want your flash to operate automatically you would set your release mode to "S" (single), where you only get one shot for each press of the shutter release button.

You mentioned that you are taking wildlife pictures, so perhaps you wanted to catch all of the action and so had it in "continuous" mode.

Just a guess...

Regards,
Fred

----------------------------------------------------
"In theory there is no difference between theory and practice, but in practice there is."

Visit my Nikonians gallery.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Forums Lobby GET TO KNOW YOUR CAMERA & MASTER IT Nikon D5300/D5200/D5100/D5000/D3300/D3200/D3100/D3000 (Public) topic #6901 Previous topic | Next topic


Take the Nikonians Tour and learn more about being a Nikonian Wiki /FAQ /Help Listen to our MP3 photography radio channels Find anything on Nikon and imaging technology - fast!

Copyright © Nikonians 2000, 2014
All Rights Reserved

Nikonians®, NikoScope® and NikoniansAcademy™ are trademarks owned by Nikonians.org.
Nikon®, Nikonos® and Nikkor® are registered trademarks of Nikon Corporation.