nikonians

Even though we ARE Nikon lovers,we are NOT affiliated with Nikon Corp. in any way.


Sign up Login
Home Forums Articles Galleries News Workshops Shop Recommended
members
All members Wiki Contests Vouchers Apps Newsletter THE NIKONIAN™ Magazines Podcasts Fundraising

Nikon D80 cable shutter MC-DC1: cable or camera malfunction??

opoloko

UK
3 posts

Click to send email to this author Click to send private message to this author
opoloko Registered since 26th Sep 2012
Wed 26-Sep-12 06:55 PM

Hi all,

for the first time I decided to use a cable shutter release as
I need to take long exposure pictures one after the other,
without staying near the camera. I found on eBay several
models by Shoot brand like this one

http://www.ebay.co.uk/itm/Timer-Remote-Shutter-Release-for-NIKON-D70s-D80-MC-DC1-/220769581310?pt=UK_Photography_DigitalCamAccess_RL&hash=item3366e478fe

I received the item, set the camera on Manual/Bulb/Manual
focus etc., but as soon as I connect the cable to the camera
it starts exposing..even without batteries in the remote. If I
connect it before switching on the camera, as soon as I switch
on the camera it starts exposing. I also tried setting
exposure time to 2 seconds..it takes the picture but when
finished it does not show the picture just taken until I
disconnect the shutter cable.

The odd thing is also that after this first picture, I cannot
use anymore the main shutter button on the camera or the one
on the remote..it just does not work. But as soon as I
disconnect the remote the previous picture appears on the back
screen, and I can use again the camera or connect the remote
but only for one picture..

If I set the timer on the remote shutter it expose correctly
the first picture, for example for 60s, but then it looks like
the camera 'hangs' without showing the picture taking and
unable to take any other picture until I disconnect the remote
shutter, the previous picture appear on the screen and all
goes back to normal.


Any idea? Could it be the cheap remote shutter cable broken?
Is it a problem of the camera? Any advice is welcome...thanks!

MEMcD

US
28347 posts

Click to send email to this author Click to send private message to this author

#1. "RE: Nikon D80 cable shutter MC-DC1: cable or camera malfunction??" | In response to Reply # 0

MEMcD Moderator In depth knowledge in various areas Nikonian since 24th Dec 2007
Wed 26-Sep-12 11:11 PM

Hi ______,

Welcome to Nikonians!
Sorry to hear of your problem.
It sounds like there is a short in the cable.
I would return it.

BTW:

We always encourage our members to fill in their real first and last names, and
have made that issue a part of our Terms of Use.

The intent is to foster a community of "real people" instead of
mysterious web-personalities with anonymous screen names. Doing this helps to
establish and maintain a safe, civil and friendly environment.

Thanks in advance.

Good Luck and Enjoy your Nikons!

Best Regards,
Marty

opoloko

UK
3 posts

Click to send email to this author Click to send private message to this author

#2. "RE: Nikon D80 cable shutter MC-DC1: cable or camera malfunction??" | In response to Reply # 1

opoloko Registered since 26th Sep 2012
Wed 26-Sep-12 11:47 PM

Hi,

thanks a lot for your reply, and sorry about the real name..I can perfectly understand and I like it so I changed it

I thought it was some sort of short, so I asked the vendor for a refund and ended up buying a better quality one from Amazon.

I'm into astrophotography and during winter I like to leave the camera outside taking series of long exposures attached to the telescope and me inside taking the pictures via usb to the computer. Sadly there's no way of triggering the shutter for bulb mode via usb so the only alternative is using a timer remote shutter.

Thanks again for your suggestion!

Adr

MEMcD

US
28347 posts

Click to send email to this author Click to send private message to this author

#3. "RE: Nikon D80 cable shutter MC-DC1: cable or camera malfunction??" | In response to Reply # 2

MEMcD Moderator In depth knowledge in various areas Nikonian since 24th Dec 2007
Thu 27-Sep-12 07:10 AM

Hi Adrian,

Again, Welcome to Nikonians!

Thanks for filling in your name.

Good luck and Enjoy your Nikons!

Best Regards,
Marty

spanglerokapi

Aylesbury, UK
115 posts

Click to send email to this author Click to send private message to this author

#4. "RE: Nikon D80 cable shutter MC-DC1: cable or camera malfunction??" | In response to Reply # 3

spanglerokapi Silver Member Nikonian since 22nd May 2008
Thu 27-Sep-12 07:20 PM

I have the same problem using an eBay remote with my D80, on stripping the remote down other than being very poorly made I can find no explanation to the problem and can only assume that the shoddy quality extends to the plug on the end of the cable.

Andrew

opoloko

UK
3 posts

Click to send email to this author Click to send private message to this author

#5. "RE: Nikon D80 cable shutter MC-DC1: cable or camera malfunction??" | In response to Reply # 4

opoloko Registered since 26th Sep 2012
Thu 27-Sep-12 08:45 PM

Thanks,

I eventually got a refund without even returning the item, and got a better one from Amazon..arriving tomorrow so let's hope it will be good this time!

G